Composer No version set (parsed as 1.0.0) is satisfiable

Posted on January 10, 2017 at 11:26 pm

If you get these error messages via composer:

Your requirements could not be resolved to an installable set of packages.
...
- The requested package library_name No version set (parsed as 1.0.0) is satisfiable by library_name[No version set (parsed as 1.0.0)] but these conflict with your requirements or minimum-stability.
...
Installation failed, reverting ./composer.json to its original content.

Make sure the composer.json has “version” set, example:

{
  "name": "layershifter/tld-extract",
  "type": "library",
  "description": "TLDExtract, library for extracting parts of domain, e.q. domain parser",
  "version": "1.2.0",
  "keywords": [
    "TLDExtract",
    "domain parser"
  ],
  "minimum-stability": "stable",
  ...

Updated on January 30, 2017 at 12:39 am

Stay Updated

Other Posts

Updated Posts