CVE-2017-5754 Patch Meltdown Vulnerability on Debian Linux

Posted on January 9, 2018 at 11:36 am

How can I patch Meltdown vulnerability CVE-2017-5754 on Debian Linux server?

First, follow the status of the Debian vulnerablities on this link:

Information on Debian source package linux

The Meltdown bugs are CVE-2017-5753, CVE-2017-5754, CVE-2017-5715:

The fixes for all the Meltdown CVEs vulnerabilities are not yet available (9 Jan 2018).

But soon they will be available and you will need to patch the kernel.

Read also: Check Linux for Spectre and Meltdown vulnerability

Patch Meltdown Vulnerability on Debian Linux

Here is a simple prodcedure that I will follow:

1) Update the package repositories with apt-get:

sudo apt-get update

2) Use uname -r to check the kernel version:

uname -r

3) With Debian you should run dist-upgrade, example:

sudo apt-get dist-upgrade

4) Then reboot your server:

sudo shutdown -r 0

5) And check the kernel version again:

uname -r

References:

An Update on AMD Processor Security
Intel Responds to Security Research Findings
Information on Debian source package linux
https://github.com/speed47/spectre-meltdown-checker
CVE-2017-5715 – Debian Security Tracker
CVE-2017-5753 – Debian Security Tracker
CVE-2017-5754 – Debian Security Tracker

Receive updates via email

Other Posts

Updated Posts