Package ‘libapache2-mod-fastcgi’ has no installation candidate

Posted on November 3, 2013 at 6:01 pm

When you try to install the package libapache2-mod-fastcgi you may get this error:

root@server:~# apt-get install libapache2-mod-fastcgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libapache2-mod-fastcgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
 
E: Package 'libapache2-mod-fastcgi' has no installation candidate

To fix this issue, just edit the apt-get sources:

vi /etc/apt/sources.list

For Debian OS, you need to add “non-free“, example:

deb http://security.debian.org/ wheezy/updates main non-free
deb-src http://security.debian.org/ wheezy/updates main non-free

For Ubuntu OS, you need to add “multiverse“, example:

deb http://archive.ubuntu.com/ubuntu quantal main multiverse universe
deb http://archive.ubuntu.com/ubuntu quantal-updates main multiverse universe
deb http://security.ubuntu.com/ubuntu quantal-security main universe multiverse

Now update apt-get with this command:

apt-get update

And try to install libapache2-mod-fastcgi:

apt-get install libapache2-mod-fastcgi

Receive updates via email

Other Posts

Updated Posts